CVE-2026-113717: virtualenv · Pip seeding with download omits wheel digest verification
Affects virtualenvwrapperSource GCVE Database
Not known to be exploited · CVSS 2.3 Low : upgrade to 6.1.1_4 when convenient.
Data as of 27 Oct 2026, 06:44 UTC
- Patch
- Available – fixed in 6.1.1_4
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade virtualenvwrapper to 6.1.1_4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewvirtualenvwrapperpkg:brew/virtualenvwrapperOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade virtualenv to version 6.1.1_4 or later, where this issue is fixed by verifying wheels before pip installation and disabling index lookup during seeding. Until then, avoid using the combination of --seeder pip with --download and untrusted or attacker-controlled pip indexes. The vendor advisory confirms a patch is available and recommends updating to the fixed version.
Description
CVE-2026-113717 is a vulnerability in virtualenv's pip seeder when used with the --download option. The issue arises because virtualenv skips wheel digest verification for wheels obtained via index lookup during pip seeding, allowing an attacker-controlled index to serve a modified pip wheel without detection. This can lead to installation of tampered pip packages in the created environment. The vulnerability requires both --seeder pip and --download options to be enabled and a non-default index configured. A fix is available in virtualenv version 6.1.1_4.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-cx28-75q4-x26q (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113717 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3430 (opens in a new tab)
- github.com/pypa/virtualenv/commit/7babec66e043e1cc8bc66869a063653898719d96 (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.9 (opens in a new tab)