CVE-2026-113717: virtualenv · Pip seeding with download omits wheel digest verification
Affects poetrySource GCVE Database
Not known to be exploited · CVSS 2.3 Low : upgrade to 2.5.1_1 when convenient.
Data as of 27 Oct 2026, 06:45 UTC
- Patch
- Available – fixed in 2.5.1_1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade poetry to 2.5.1_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpoetrypkg:brew/poetryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in virtualenv version 2.5.1_1 that fixes this issue by verifying wheels before invoking pip with index lookup disabled. Users should upgrade to version 2.5.1_1 or later. Until patched, avoid using the combination of --seeder pip and --download options with untrusted or attacker-controlled package indexes. The default app-data seeder remains protected by digest verification. No additional generic mitigations are required beyond applying the official fix.
Description
CVE-2026-113717 is a vulnerability in virtualenv's pip seeder when used with the --download option. The issue arises because the pip seeder downloads bundled wheels with download=False, skipping virtualenv's wheel digest verification. This allows an attacker controlling the index configured in pip.conf to serve a modified pip wheel that bypasses the digest check, potentially installing tampered code. The vulnerability requires both --seeder pip and --download options to be enabled. A fix is available in virtualenv version 2.5.1_1.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-cx28-75q4-x26q (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113717 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3430 (opens in a new tab)
- github.com/pypa/virtualenv/commit/7babec66e043e1cc8bc66869a063653898719d96 (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.9 (opens in a new tab)