CVE-2026-113717: virtualenv · Pip seeding with download omits wheel digest verification
Affects toxSource GCVE Database
Not known to be exploited · CVSS 2.3 Low : upgrade to 4.67.0 when convenient.
Data as of 27 Oct 2026, 06:44 UTC
- Patch
- Available – fixed in 4.67.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade tox to 4.67.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewtoxpkg:brew/toxOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade virtualenv to version 4.67.0 or later, where this issue is fixed by verifying wheels before invoking pip with index lookup disabled. Until then, avoid using the combination of --seeder pip and --download options together, or ensure that pip indexes are trusted and not attacker-controlled. The vendor has provided an official fix, so applying the update is the recommended remediation.
Description
A vulnerability in virtualenv's pip seeder with the --download option allows installation of pip wheels from an index without verifying the wheel's SHA-256 digest against PyPI metadata. This occurs because the pip seeder skips virtualenv's wheel digest verification when downloading wheels, potentially allowing a malicious index to serve a modified pip wheel that is installed without integrity checks. Both --seeder pip and --download options must be used to trigger this issue. The vulnerability affects virtualenv versions from 4.62.0 up to but not including 4.67.0 and has a low severity score.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-cx28-75q4-x26q (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113717 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3430 (opens in a new tab)
- github.com/pypa/virtualenv/commit/7babec66e043e1cc8bc66869a063653898719d96 (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.9 (opens in a new tab)