CVE-2026-113718: virtualenv · Xonsh activation literals depend on the script decoding codec
Affects noxSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 2026.10.20 soon.
Data as of 27 Oct 2026, 06:56 UTC
- Patch
- Available – fixed in 2026.10.20
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade nox to 2026.10.20.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewnoxpkg:brew/noxOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading virtualenv to version 2026.10.20 or later. This update changes the quoting mechanism to use ascii() escapes, preventing non-ASCII characters from breaking string literals under legacy encodings. Existing activate.xsh files should be regenerated after applying the fix. No other mitigations are indicated by the vendor advisory.
Description
A vulnerability in virtualenv's xonsh activation script allows attacker-controlled prompt text to become executable syntax when the activation script is decoded using legacy multibyte encodings such as GBK or Big5. This occurs because the script is written in UTF-8 but read with a different codec, causing escape sequences to be misinterpreted and enabling code execution during environment activation. The issue affects POSIX activation scripts and requires an attacker to control the prompt or destination data passed to virtualenv and for the user to activate the environment with the affected encoding. A fix is available in version 2026.10.20.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-394h-qwmc-48pf (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113718 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3432 (opens in a new tab)
- github.com/pypa/virtualenv/commit/e5fc2e6e189a877ff559af288919e3525d13e5e0 (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.9 (opens in a new tab)