CVE-2026-113718: virtualenv · Xonsh activation literals depend on the script decoding codec
Affects poetrySource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 2.5.1_1 soon.
Data as of 27 Oct 2026, 06:43 UTC
- Patch
- Available – fixed in 2.5.1_1
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade poetry to 2.5.1_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpoetrypkg:brew/poetryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in virtualenv version 2.5.1_1 that changes the quoting method to escape non-ASCII characters, preventing the decoding ambiguity. Users should upgrade to version 2.5.1_1 or later and regenerate any existing activate.xsh files to ensure they are not vulnerable. No other mitigation is required if the fix is applied.
Description
A vulnerability in virtualenv's xonsh activation script allows attacker-controlled prompt text to become executable code during environment activation if the xonsh source decoding uses legacy multibyte encodings like GBK or Big5. This occurs because the UTF-8 encoded activation script is read with a different codec, causing escape characters to be misinterpreted and enabling code injection. The issue affects POSIX activation scripts and requires an attacker to control the prompt or destination argument passed to virtualenv and a user to activate the environment with the affected encoding. A fix is available in virtualenv version 2.5.1_1.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-394h-qwmc-48pf (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113718 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3432 (opens in a new tab)
- github.com/pypa/virtualenv/commit/e5fc2e6e189a877ff559af288919e3525d13e5e0 (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.9 (opens in a new tab)