Skip to main content
CVE-2024-53899VulnerabilityPublished Updated

Virtualenvwrapper: virtualenv allows command injection through activation scripts for a virtual environment

Affects virtualenvwrapperSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-53899· High 8.4

Not known to be exploited · CVSS 8.4 High : upgrade to 6.1.1 or 4.8.4_2 soon.

Data as of 30 Oct 2026, 05:15 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.1.1, 4.8.4_2
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade virtualenvwrapper to 6.1.1 or 4.8.4_2.

Affected software

ProductAffectedFixed in
Homebrewvirtualenvwrapperpkg:brew/virtualenvwrapperOther threatsAffected
  • >=4.8.4 <4.8.4_2
  • >=6.1.0 <6.1.1
Fixed in
  • 4.8.4_2
  • 6.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

virtualenv before 20.26.6 allows command injection through the activation scripts for a virtual environment. Magic template strings are not quoted correctly when replacing. NOTE: this is not the same as CVE-2024-9287.

References

Community reviews

Loading reviews…