Skip to main content
VulnerabilityPublished Updated

CVE-2026-7141: vLLM makes Use of Uninitialized Resource

Affects vllmSource GCVE Database

0
Authoritative record:CVE-2026-7141· Medium 6.3

Public exploit available · CVSS 6.3 Medium : upgrade to 0.19.1 as a priority.

Data as of 27 Oct 2026, 02:11 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.19.1
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade vllm to 0.19.1.

Affected software

ProductAffectedFixed in
PyPIvllmAffected
  • <0.19.1
Fixed in
  • 0.19.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in vLLM version 0.19.1. It is recommended to upgrade to this version to remediate the vulnerability. No other mitigations or workarounds are indicated by the vendor advisory.

Description

CVE-2026-7141 is a vulnerability in vLLM versions prior to 0.19.1 affecting the has_mamba_layers function in the KV Block Handler component. It involves use of an uninitialized resource that can be triggered remotely. The vulnerability has a medium severity with a CVSS score of 5.6. A patch is available in version 0.19.1 to address this issue.

References

Community reviews

Loading reviews…