Skip to main content
VulnerabilityPublished

VU#280377: Dokploy is vulnerable to OS command injection

Source CERT/CC

0

Fixed in 0.29.13 : patch affected systems as a priority.

Data as of 17 Sep 2026, 15:15 UTC

Severity
Critical

Rated Critical by Threat Radar from the CERT/CC text

Patch
Available – fixed in 0.29.13

What to do

AI-suggested

A fix is available in Dokploy version 0.29.13 and later; users should update immediately. For those unable to update promptly, it is recommended to disable default backup permissions or restrict them strictly to necessary users and roles to reduce the risk of exploitation.

Description

Dokploy versions 0.29.8 and 0.29.11, as well as commit 24b02f5 on the canary branch, contain an OS command injection vulnerability in their database backup creation and restoration processes. This occurs because user-supplied input is unsafely incorporated into shell commands executed with root privileges. Authenticated users with backup permissions can exploit this to execute arbitrary commands as root, potentially leading to full system compromise. The vulnerability affects all supported database types: PostgreSQL, MySQL, MariaDB, MongoDB, and LibSQL. The issue has been patched in Dokploy version 0.29.13 and later. Users unable to update should restrict backup permissions to mitigate risk.

References

Community reviews

Loading reviews…