core of Apache HTTP Server · Untrusted Functionality Inclusion
Source GCVE Database
Not known to be exploited · CVSS 9.8 Critical · fixed in 2.4.60 : patch Apache HTTP Server as a priority.
Data as of 29 Oct 2026, 22:52 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 9.8 |
|---|
- Patch
- Available – fixed in 2.4.60
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Apacheapache/httpdpkg:rpm/apache/httpdOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Vulnerability in core of Apache HTTP Server 2.4.59 and earlier are vulnerably to information disclosure, SSRF or local script execution via backend applications whose response headers are malicious or exploitable. Users are recommended to upgrade to version 2.4.60, which fixes this issue.
References
- nvd.nist.gov/vuln/detail/CVE-2024-38476 (opens in a new tab)
- httpd.apache.org/security/vulnerabilities_24.html (opens in a new tab)
- security.netapp.com/advisory/ntap-20240712-0001 (opens in a new tab)
- seclists.org/fulldisclosure/2024/Oct/11 (opens in a new tab)
- openwall.com/lists/oss-security/2024/07/01/9 (opens in a new tab)