Skip to main content
VulnerabilityPublished Updated

CVE-2024-21218: Uncontrolled Resource Consumption

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-21218· Medium 4.9

Not known to be exploited · CVSS 4.9 Medium · fixed in 9.0.2 : update MySQL Cluster when convenient.

Data as of 30 Oct 2026, 02:15 UTC

CVSS 3.1 base score
4.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (oracle)CVSS 3.14.9
Patch
Available – fixed in 9.0.2, 8.4.3, 8.0.40
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mysql/mysql-cluster to 9.0.2, 8.4.3 or 8.0.40.

Affected software

ProductAffectedFixed in
Mysqlmysql/mysql-clusterpkg:deb/mysql/mysql-clusterOther threatsAffected
  • <8.0.40
  • <8.4.3
  • <9.0.2
Fixed in
  • 8.0.40
  • 8.4.3
  • 9.0.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Oracle has released security patches for this vulnerability as part of its October 2024 Critical Patch Update. Users should apply the relevant patches promptly to mitigate this issue. Oracle strongly recommends running actively supported versions and applying Critical Patch Updates without delay. No alternative mitigations or workarounds are specified.

Description

A vulnerability exists in the InnoDB component of Oracle MySQL Server affecting versions 8.0.39 and prior, 8.4.2 and prior, and 9.0.1 and prior. This flaw allows a high-privileged attacker with network access to cause a denial of service by hanging or crashing the MySQL Server. The vulnerability has a CVSS 3.1 base score of 4.9, indicating a medium severity impact focused on availability.

References

Community reviews

Loading reviews…