CVE-2024-20970
Source GCVE Database
Not known to be exploited · CVSS 4.9 Medium : upgrade to 8.2.1 or 8.0.36 when convenient.
Data as of 4 Nov 2026, 17:40 UTC
Thin evidence
One scorer or none| CNA (oracle) | CVSS 3.1 | 4.9 |
|---|
- Patch
- Available – fixed in 8.2.1, 8.0.36
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Feb 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade mysql/mysql-server to 8.2.1 or 8.0.36.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mysqlmysql/mysql-serverpkg:deb/mysql/mysql-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Oracle has released security patches for this vulnerability in the January 2024 Critical Patch Update. Customers are strongly advised to apply these patches promptly to mitigate the risk. Remaining on actively supported versions and applying Critical Patch Updates without delay is recommended. No alternative mitigations or workarounds are specified.
Description
CVE-2024-20970 is a vulnerability in the Oracle MySQL Server's optimizer component affecting versions 8.0.35 and prior, and 8.2.0 and prior. It allows a high-privileged attacker with network access to cause a denial of service by hanging or crashing the MySQL Server. The vulnerability impacts availability but does not affect confidentiality or integrity. Oracle has released patches addressing this and many other vulnerabilities in their January 2024 Critical Patch Update.