CVE-2025-21567: Incorrect Authorization
Source GCVE Database
Not known to be exploited · CVSS 4.3 Medium : upgrade to 9.1.1 when convenient.
Data as of 30 Oct 2026, 01:04 UTC
Thin evidence
One scorer or none| CNA (oracle) | CVSS 3.1 | 4.3 |
|---|
- Patch
- Available – fixed in 9.1.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mysql/mysql-server to 9.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mysqlmysql/mysql-serverpkg:deb/mysql/mysql-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Oracle has released security patches for this vulnerability in the January 2025 Critical Patch Update. Users are strongly advised to apply these official patches promptly to remediate the issue. No alternative mitigations or workarounds are indicated in the advisory.
Description
A vulnerability in Oracle MySQL Server (CVE-2025-21567) affects versions 9.1.0 and earlier. It allows a low-privileged attacker with network access via multiple protocols to gain unauthorized read access to some MySQL Server data. The vulnerability has a CVSS 3.1 base score of 4.3, indicating a medium severity with confidentiality impact only. Oracle has released patches for this and many other vulnerabilities in its January 2025 Critical Patch Update advisory.