Skip to main content
VulnerabilityPublished

CVE-2026-34086: Wikimedia Foundation AbuseFilter · Improper Input Validation

Source GCVE Database

0
Authoritative record:CVE-2026-34086· Low 2.1

Not known to be exploited · CVSS 2.1 Low : upgrade to 1.43.7 when convenient.

Data as of 27 Oct 2026, 00:13 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.43.7
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/S:N/AU:Y

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade AbuseFilter to 1.43.7.

Affected software

ProductAffectedFixed in
Wikimedia FoundationAbuseFilterAffected
  • < 1.43.7, 1.44.4, 1.45.2
Fixed in
  • 1.43.7

Description

A low-severity vulnerability (CVE-2026-34086) exists in the Wikimedia Foundation AbuseFilter component affecting versions before 1.43.7, 1.44.4, and 1.45.2. The issue is categorized under CWE-20 (Improper Input Validation).

References

Community reviews

Loading reviews…