Skip to main content
VulnerabilityPublished Updated

Wagtail: Improper restriction handling on Page translation API endpoint

Affects wagtailSource GCVE Database

0

CVSS 6.5 Medium : upgrade to 7.0.9 when convenient.

Data as of 26 Oct 2026, 16:14 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 7.0.9, 7.3.4, 7.4.3 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PyPIwagtailAffected
  • <7.0.9
Fixed in
  • 7.0.9
PyPIwagtailAffected
  • >=7.1rc1 <7.3.4
Fixed in
  • 7.3.4
PyPIwagtailAffected
  • >=7.4rc1 <7.4.3
Fixed in
  • 7.4.3
PyPIwagtailAffected
  • >=8.0rc1 <8.0rc2
  • =8.0rc1
Fixed in
  • 8.0rc2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

### Impact A CMS user with the "submit translations" permission, could use the Admin API's "copy for translation" endpoint to copy an existing page that they do not have edit access to, allowing them to view its contents. ### Patches Patched versions have been released as Wagtail 7.0.9, 7.3.4, 7.4.3 and 8.0rc2. ### Workarounds N/A ### Acknowledgements Many thanks to tinyb0y for reporting this issue. ### For more information If you have any questions or comments about this advisory: * Visit Wagtail's [support channels](https://docs.wagtail.org/en/stable/support.html) * Email us at [security@wagtail.org](mailto:security@wagtail.org) (view our [security policy](https://github.com/wagtail/wagtail/security/policy) for more information).

References

Community reviews

Loading reviews…