Skip to main content
CVE-2026-119131VulnerabilityPublished

Wasmtime 46.0.0 before 48.0.6 and 49.0.0 before 49.0.3 contains a denial of service vulnerability in

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-119131· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 49.0.3 or 48.0.6 when convenient.

Data as of 29 Oct 2026, 19:44 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.15.3
Patch
Available – fixed in 49.0.3, 48.0.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade wasmtime to 49.0.3 or 48.0.6.

Affected software

ProductAffectedFixed in
bytecodealliancewasmtimeAffected
  • >=49.0.0 <49.0.3
Fixed in
  • 49.0.3
bytecodealliancewasmtimeAffected
  • >=46.0.0 <48.0.6
Fixed in
  • 48.0.6
crates.iowasmtimepkg:cargo/wasmtimeOther threatsAffected
  • >=46.0.0 <48.0.6
  • >=49.0.0 <49.0.3
Fixed in
  • 48.0.6
  • 49.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Wasmtime versions 48.0.6 and 49.0.3 and later. Users should upgrade to these or newer versions to remediate the vulnerability. No other mitigation steps are indicated.

Description

Wasmtime versions 46.0.0 before 48.0.6 and 49.0.0 before 49.0.3 contain a denial of service vulnerability in the wasmtime-wasi-http component. This flaw allows guest code to crash the host by sending long request URLs that overflow a 16-bit index in the HTTP crate, causing a host panic.

References

Community reviews

Loading reviews…