Skip to main content
VulnerabilityPublished Updated

CVE-2025-12218: Weak Default Credentials.This issue affects BLU-IC2: through 1.19.5; BLU-IC4: through 1.19.5

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-12218· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical · fixed in 1.19.6 : patch BLU-IC2 and BLU-IC4 devices as a priority.

Data as of 7 Nov 2026, 17:21 UTC

CVSS 4.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
Affects
BLU-IC2 and BLU-IC4 devices up to 1.19.5
Patch
Available – fixed in 1.19.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

AI-suggested

If you cannot patch yet, it is recommended to change default credentials to strong, unique passwords and restrict network access to affected devices where possible.

Description

CVE-2025-12218 is a critical vulnerability involving weak default credentials in BLU-IC2 and BLU-IC4 devices up to version 1.19.5. This weakness allows unauthenticated remote attackers to gain high-impact access, compromising confidentiality and integrity without requiring user interaction.

References

Community reviews

Loading reviews…