Welotec: PHP2Shell Vulnerabilities
Affects WelotecSource GCVE Database
Exploited in the wild · KEV due 29 Oct 2026 · public exploit available (Exploit-DB) · 99% EPSS · fixed in 8.5.12 : patch Welotec now.
Data as of 29 Oct 2026, 14:41 UTC
Thin evidence
One scorer or none| CNA (php) | CVSS 4.0 | 9.2 |
|---|
- KEV deadline
- US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
- EPSS
- 99.9% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.5.12, 8.4.27, 8.3.36 +1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: evidence found.
nuclei template: PHP2Shell (CVE-2026-109618/CVE-2026-109619) - Active Crash Detection
Weaponized: evidence found.
Exploited in the wildExploited: evidence found.
Listed in CISA KEV 5 days after disclosure
Observed by OffSeq MirageSeen by Mirage: evidence found.
81 honeypot hits, first 43 hours after disclosure
Timeline
CVE ID reserved
by PHP Group
, 9 days before disclosure
CVE published
on cve.org
, t = 0
First Exploit-DB entry (opens in a new tab)
PHP2Shell (CVE-2026-109618) - PHP core versions after v5.4 - RCE
, 1 day after disclosure
First seen by OffSeq Mirage
from 10 attacker networks; activity in Portugal, Netherlands, Monaco, Germany and 12 more
, 43 hours after disclosure
In Threat Radar
record ingested
, 5 days after disclosure
Added to CISA KEV (opens in a new tab)
exploitation confirmed
, 5 days after disclosure
Last seen by OffSeq Mirage (opens in a new tab)
28 Oct 2026, 19:29 UTC
, 7 days after disclosure
KEV remediation due
US federal deadline
, 8 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), OffSeq Mirage (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade PHP to 8.5.12, 8.4.27, 8.3.36 or 8.2.35.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PHPphp-src | Affected
| Fixed in
|
| PHPphp-src | Affected
| Fixed in
|
| PHPphp-src | Affected
| Fixed in
|
| PHPphp-src | Affected
| Fixed in
|
Description
Two memory-safety vulnerabilities in the PHP runtime bundled with Welotec's SMART EMS product up to version 3.5.3 allow unauthenticated remote attackers to execute arbitrary code in the PHP web worker context. Exploitability depends on server interface, configuration, application behavior, and worker reuse. Public exploit code is available.