Skip to main content
CVE-2025-47273VulnerabilityPublished Updated

Yamlfix: setuptools has a path traversal vulnerability in PackageIndex.download that leads to Arbitrary File Write

Affects yamlfixSource GCVE Database

0

Public exploit available · CVSS 8.7 High : upgrade to 1.17.0_1 as a priority.

Data as of 26 Oct 2026, 19:32 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.17.0_1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade yamlfix to 1.17.0_1.

Affected software

ProductAffectedFixed in
Homebrewyamlfixpkg:brew/yamlfixOther threatsAffected
  • >=1.17.0 <1.17.0_1
Fixed in
  • 1.17.0_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in setuptools version 1.17.0_1. Users should upgrade to this version or later to remediate the vulnerability. Since the affected components are deprecated, reducing usage of easy_install and package_index also mitigates risk.

Description

A path traversal vulnerability in setuptools' PackageIndex.download function allows an attacker to write files to arbitrary filesystem locations with the permissions of the running process. The flaw arises from insufficient sanitization of URL-derived filenames used in os.path.join, enabling path traversal despite some replacement of '..' sequences. This vulnerability was fixed in setuptools version 1.17.0_1. Exploitation could lead to arbitrary file write and potentially remote code execution depending on context. The affected component is deprecated, reducing the attack surface.

References

Community reviews

Loading reviews…