YesWiki before 4.7.0 contains a server-side request forgery vulnerability in DuplicationManager::downloadFile() that
Affects yeswikiSource GCVE Database
Not known to be exploited · CVSS 8.2 High : upgrade to 4.7.0 soon.
Data as of 27 Oct 2026, 01:59 UTC
- Patch
- Available – fixed in 4.7.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade yeswiki/yeswiki to 4.7.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubyeswiki/yeswikipkg:github/yeswiki/yeswikiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 4.7.0 or later should be applied once available. Until then, restrict administrator access to trusted users only and monitor for suspicious activity related to the /api/pages/{tag}/duplicate endpoint.
Description
YesWiki versions prior to 4.7.0 have a server-side request forgery (SSRF) vulnerability in the DuplicationManager::downloadFile() function. This flaw allows authenticated administrators to send arbitrary outbound requests by manipulating the files array. Exploitation can lead to attackers posting file:// or internal URLs to the /api/pages/{tag}/duplicate endpoint, resulting in local files, cloud metadata, or database credentials being stored in a publicly accessible directory.