YesWiki before 4.7.0 contains a sql injection vulnerability in despam.php where the from parameter is escaped but
Affects yeswikiSource GCVE Database
Not known to be exploited · CVSS 6.9 Medium : upgrade to 4.7.0 when convenient.
Data as of 27 Oct 2026, 01:59 UTC
- Patch
- Available – fixed in 4.7.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade yeswiki/yeswiki to 4.7.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubyeswiki/yeswikipkg:github/yeswiki/yeswikiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to YesWiki version 4.7.0 or later once available. Until then, restrict administrator access to trusted personnel only and monitor for suspicious activity.
Description
YesWiki versions prior to 4.7.0 have a SQL injection vulnerability in the despam.php script. The flaw arises because the 'from' POST parameter is escaped but used in an unquoted INTERVAL context, allowing authenticated administrators to perform blind SQL injection. This can lead to unauthorized reading of database contents, including user password hashes.