YesWiki before 4.7.0 contains a stored cross-site scripting vulnerability in handlers/page/referrers_sites.php that
Affects yeswikiSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.7.0 when convenient.
Data as of 27 Oct 2026, 01:59 UTC
- Patch
- Available – fixed in 4.7.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade yeswiki/yeswiki to 4.7.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubyeswiki/yeswikipkg:github/yeswiki/yeswikiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in YesWiki version 4.7.0 and later. Users should upgrade to version 4.7.0 or newer to remediate this vulnerability. Until upgrading, users should be cautious about visiting referrer-sites pages with untrusted Referer headers.
Description
YesWiki versions prior to 4.7.0 have a stored cross-site scripting (XSS) vulnerability in the handlers/page/referrers_sites.php component. This flaw allows unauthenticated attackers to inject malicious scripts via specially crafted Referer headers. When a victim visits the referrer-sites page, the injected JavaScript executes in their browser context, enabling same-origin authenticated actions.