CVE-2026-52778: yeswiki/yeswiki · YesWiki has Unsafe eval()
Affects yeswiki/yeswikiSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical : upgrade to 4.6.6 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.6.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade yeswiki/yeswiki to 4.6.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistyeswiki/yeswiki | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, it is recommended to disable or avoid using the vulnerable Bazar form field calculator feature. Do not rely on regular expressions to sanitize input for eval(). Instead, replace the vulnerable code with a dedicated, safe Abstract Syntax Tree (AST) math parser or a secure expression language component that does not execute system context code.
Description
YesWiki versions prior to 4.6.6 contain a critical vulnerability in the Bazar form field calculator (CalcField.php) where user-defined formulas are validated by a complex recursive regular expression before being passed to PHP's eval() function. This approach is flawed, allowing attackers to cause a Denial of Service via PCRE stack overflow or potentially bypass validation to execute arbitrary PHP code remotely. The vulnerability impacts confidentiality, integrity, and availability of the affected system.
References
- github.com/YesWiki/yeswiki/security/advisories/GHSA-px5m-h76g-p7p8 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-52778 (opens in a new tab)
- github.com/YesWiki/yeswiki/commit/dd2bd8fb099de0d21504bda8a810693b3fcb8e52 (opens in a new tab)
- github.com/YesWiki/yeswiki (opens in a new tab)
- github.com/YesWiki/yeswiki/releases/tag/v4.6.6 (opens in a new tab)