Skip to main content
VulnerabilityPublished

CVE-2026-52774: yeswiki/yeswiki · YesWiki Vulnerable to Reflected XSS via Unescaped `id` Parameter in Bazar Widget HTML Attributes

Affects yeswiki/yeswikiSource GCVE Database

0
Compare

Not known to be exploited · public detection template (Nuclei) · CVSS 6.1 Medium : upgrade to 4.6.6 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.6.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jul 2026

  2. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade yeswiki/yeswiki to 4.6.6.

Affected software

ProductAffectedFixed in
Packagistyeswiki/yeswikiAffected
  • <4.6.6
Fixed in
  • 4.6.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider disabling the Bazar extension if it is not needed or implement web application firewall (WAF) rules to detect and block suspicious requests targeting the `id` parameter in the widget route. Avoid exposing the vulnerable endpoint to untrusted users.

Description

YesWiki versions prior to 4.6.6 with the Bazar extension enabled are vulnerable to a reflected cross-site scripting (XSS) issue. The vulnerability arises because the `id` GET parameter is inserted into HTML attributes without proper escaping, using only `strip_tags()`, which does not neutralize double quotes. This allows attackers to inject arbitrary HTML attributes and JavaScript event handlers, leading to script execution in the victim's browser. The vulnerable endpoint is accessible without authentication or any access control checks, and does not require valid page tags or edit rights. An attacker can craft a URL that, when visited by a victim, triggers the injected script. This vulnerability is classified as CWE-79 and has a moderate severity rating.

References

Community reviews

Loading reviews…