Skip to main content
VulnerabilityPublished Updated

CVE-2026-26331: yt-dlp · Arbitrary Command Injection when using the `--netrc-cmd` option

Affects scdlSource GCVE Database

0

Not known to be exploited · CVSS 8.8 High : upgrade to 3.0.4 soon.

Data as of 26 Oct 2026, 17:58 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.8% chance of exploitation in 30 days – higher than 78% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade scdl to 3.0.4.

Affected software

ProductAffectedFixed in
Homebrewscdlpkg:brew/scdlOther threatsAffected
  • >=3.0.0 <3.0.4
Fixed in
  • 3.0.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade yt-dlp to version 3.0.4 or later, which includes validation of netrc "machine" values to prevent command injection. If upgrading is not possible, avoid using the `--netrc-cmd` option or the `netrc_cmd` Python API parameter, or do not include the placeholder `{}` in the command argument.

Description

yt-dlp versions >=3.0.0 <3.0.4 contain a high-severity vulnerability (CVE-2026-26331) involving arbitrary command injection via the `--netrc-cmd` option or `netrc_cmd` Python API parameter. This occurs when a maliciously crafted URL is processed, allowing shell command injection due to unsafe handling of the netrc "machine" value in certain extractors. The vulnerability is fixed in version 3.0.4.

References

Community reviews

Loading reviews…