CVE-2026-26331: yt-dlp · Arbitrary Command Injection when using the `--netrc-cmd` option
Affects yt-dlpSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 2026.7.4 soon.
Data as of 30 Oct 2026, 07:30 UTC
- Patch
- Available – fixed in 2026.7.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade yt-dlp to 2026.7.4.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewyt-dlppkg:brew/yt-dlpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
yt-dlp is a command-line audio/video downloader. Starting in version 2023.06.21 and prior to version 2026.02.21, when yt-dlp's `--netrc-cmd` command-line option (or `netrc_cmd` Python API parameter) is used, an attacker could achieve arbitrary command injection on the user's system with a maliciously crafted URL. yt-dlp maintainers assume the impact of this vulnerability to be high for anyone who uses `--netrc-cmd` in their command/configuration or `netrc_cmd` in their Python scripts. Even though the maliciously crafted URL itself will look very suspicious to many users, it would be trivial for a maliciously crafted webpage with an inconspicuous URL to covertly exploit this vulnerability via HTTP redirect. Users without `--netrc-cmd` in their arguments or `netrc_cmd` in their scripts are unaffected. No evidence has been found of this exploit being used in the wild. yt-dlp version 2026.02.21 fixes this issue by validating all netrc "machine" values and raising an error upon unexpected input. As a workaround, users who are unable to upgrade should avoid using the `--netrc-cmd` command-line option (or `netrc_cmd` Python API parameter), or they should at least not pass a placeholder (`{}`) in their `--netrc-cmd` argument.
References
- github.com/yt-dlp/yt-dlp/releases/tag/2026.02.21 (opens in a new tab)
- github.com/CVEProject/cvelistV5/tree/main/cves/2026/26xxx/CVE-2026-26331.json (opens in a new tab)
- github.com/yt-dlp/yt-dlp/security/advisories/GHSA-g3gw-q23r-pgqm (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-26331 (opens in a new tab)
- github.com/yt-dlp/yt-dlp/commit/1fbbe29b99dc61375bf6d786f824d9fcf6ea9c1a (opens in a new tab)