CVE-2025-43859: Zabbix cli · h11 accepts some malformed Chunked-Encoding bodies
Affects zabbix-cliSource GCVE Database
Not known to be exploited · CVSS 9.1 Critical : upgrade to 3.5.2_1 as a priority.
Data as of 27 Oct 2026, 23:13 UTC
- Patch
- Available – fixed in 3.5.2_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade zabbix-cli to 3.5.2_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewzabbix-clipkg:brew/zabbix-cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in h11 version 0.15.0, which fixes the chunked encoding parsing to strictly require correct '\r\n' terminators. Updating zabbix-cli to version 3.5.2_1 or later, which includes this fix, mitigates the vulnerability. Alternatively, fixing the proxy to correctly parse chunked encoding also mitigates the issue. Since exploitation requires both components to be vulnerable, remediating either the server or the proxy is sufficient.
Description
A vulnerability in h11's HTTP/1.1 chunked transfer encoding parsing allows malformed chunked bodies to be accepted. This leniency can cause request smuggling when combined with a buggy proxy that parses chunked bodies differently. The issue is fixed in h11 version 0.15.0. Exploitation requires both a vulnerable h11 and a buggy proxy, but can lead to request smuggling attacks that may allow attackers to bypass protections or steal credentials.
References
- github.com/python-hyper/h11/security/advisories/GHSA-vqfr-h8mv-ghfj (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-43859 (opens in a new tab)
- github.com/python-hyper/h11/commit/114803a29ce50116dc47951c690ad4892b1a36ed (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/h11/PYSEC-2026-348.yaml (opens in a new tab)
- github.com/python-hyper/h11 (opens in a new tab)
- pypi.org/project/h11 (opens in a new tab)