Skip to main content
Report · Zero Day InitiativeAbout CVE-2026-18265Published

ZDI-26-480: OSNEXUS QuantaStor Missing Authentication Remote Code Execution Vulnerability

Source Zero Day Initiative

0
Compare
Authoritative record:CVE-2026-18265· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical · patch available : patch QuantaStor as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.0 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
OSNEXUSQuantaStorAffected
  • =6.7.3.010+9c965a6414
Fixed in–

AI-suggested

A vendor-provided patch is available in QuantaStor version 6.8.0. Users should upgrade to version 6.8.0 or later to remediate this vulnerability. No other mitigation is indicated by the vendor advisory.

Description

OSNEXUS QuantaStor Missing Authentication Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of OSNEXUS QuantaStor. Authentication is not required to exploit this vulnerability. The specific flaw exists within the configuration of Kapacitor. The issue results from the lack of authentication prior to allowing access to functionality. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-30036.

References

Community reviews

Loading reviews…