Skip to main content
VulnerabilityPublished

CVE-2026-109089: libXi · buffer overflow when handling DEVICE_RESOLUTION

Source GCVE Database

0
Authoritative record:CVE-2026-109089· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 1.8.4 soon.

Data as of 27 Oct 2026, 19:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.8.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade libXi to 1.8.4.

Affected software

ProductAffectedFixed in
X.OrglibXiAffected
  • <1.8.4
Fixed in
  • 1.8.4

AI-suggested

A fix is available in libXi version 1.8.4. Users should upgrade to version 1.8.4 or later to remediate this vulnerability. No additional mitigation guidance is provided.

Description

A buffer overflow vulnerability exists in libXi before version 1.8.4 when handling DEVICE_RESOLUTION. This flaw could cause a heap overflow triggered by a malicious X server, potentially leading to high impact on confidentiality, integrity, and availability.

References

Community reviews

Loading reviews…