Skip to main content
VulnerabilityPublished

CVE-2026-109090: A malicious X server could cause a heap overflow by injecting a large DEVICE_ENABLE reply when

Source GCVE Database

0
Authoritative record:CVE-2026-109090· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 1.8.4 soon.

Data as of 27 Oct 2026, 19:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.8.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade libXi and x.org/libxi to 1.8.4.

Affected software

ProductAffectedFixed in
x.orglibXiAffected
  • <1.8.4
Fixed in
  • 1.8.4
X.orgx.org/libxipkg:deb/x.org/libxiOther threatsAffected
  • <1.8.4
Fixed in
  • 1.8.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in libXi version 1.8.4. Users and administrators should upgrade to version 1.8.4 or later to remediate this vulnerability. No other mitigations or vendor advisories are provided.

Description

CVE-2026-109090 is a heap overflow vulnerability in libXi versions before 1.8.4. It occurs when a malicious X server sends an excessively large DEVICE_ENABLE reply, which is improperly handled by libXi. This flaw can lead to high impact on confidentiality, integrity, and availability.

References

Community reviews

Loading reviews…