Skip to main content
CVE-2026-32327VulnerabilityPublished

APR-util · Bug

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-32327· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 1.6.4 : patch Apache Portable Runtime Utility as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Portable Runtime UtilityAffected
  • <=1.6.3
Fixed in–

AI-suggested

Users should upgrade to APR-util version 1.6.4, which contains the fix for this vulnerability. No other mitigations are indicated or necessary once the upgrade is applied.

Description

A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

References

Community reviews

Loading reviews…