Skip to main content
CVE-2025-12155VulnerabilityPublished

A Command Injection vulnerability, resulting from improper file path sanitization (Directory Traversal) in Looker

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-12155· High 7.1

Not known to be exploited · CVSS 7.1 High.

Data as of 7 Nov 2026, 17:18 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/S:P/AU:Y/U:Red

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

AI-suggested

Looker-hosted instances have been mitigated by the vendor and require no user action. Self-hosted Looker instances must be upgraded immediately to one of the patched versions listed (24.12.100+, 24.18.192+, 25.0.69+, 25.6.57+, 25.8.39+, or 25.10.22+) available from the Looker download page to remediate this vulnerability.

Description

A Command Injection vulnerability in Looker due to improper file path sanitization (Directory Traversal) allows an attacker with Developer permissions to execute arbitrary shell commands when a user is deleted on the host system. Looker-hosted instances have been mitigated and require no user action. Self-hosted instances must upgrade to patched versions to address this vulnerability.

References

Community reviews

Loading reviews…