CVE-2025-12155: Google Cloud Looker · Command Injection
Affects Google Cloud LookerSource CVE Database V5
Not known to be exploited · CVSS 7.1 High.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/S:P/AU:Y/U:RedExploitation evidence
Disclosed: evidence found.
CVE published 10 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Google Cloud Looker | Affected
| Fixed in– |
AI-suggested
European organizations using self-hosted Looker instances should immediately upgrade to one of the patched versions: 24.12.100+, 24.18.192+, 25.0.69+, 25.6.57+, 25.8.39+, or 25.10.22+. Prior to upgrading, conduct a thorough audit of Developer permissions to ensure only trusted personnel have such access, minimizing the risk of insider exploitation. Implement strict access controls and monitor developer activities for suspicious behavior. Employ host-based intrusion detection systems (HIDS) to detect anomalous command executions. Regularly review and sanitize user management workflows to prevent injection opportunities. Network segmentation can limit the impact of a compromised Looker host. Additionally, maintain up-to-date backups of Looker configurations and data to enable rapid recovery if compromise occurs. Finally, stay informed about any emerging exploit reports or additional patches from Google Cloud.
Description
A Command Injection vulnerability, resulting from improper file path sanitization (Directory Traversal) in Looker allows an attacker with Developer permission to execute arbitrary shell commands when a user is deleted on the host system. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 24.12.100+ * 24.18.192+ * 25.0.69+ * 25.6.57+ * 25.8.39+ * 25.10.22+