rcmail_action_mail_get->run() · Cross-Site Scripting Vulnerability
Affects roundcubeSource GCVE Database
Not known to be exploited · CVSS 9.3 Critical · fixed in 1.5.0+dfsg.1-2ubuntu0.1~esm6 : patch roundcube as a priority.
Data as of 27 Oct 2026, 00:17 UTC
- Patch
- Available – fixed in 1.5.0+dfsg.1-2ubuntu0.1~esm6, 1.6.6+dfsg-2ubuntu0.1+esm3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu roundcube to 1.5.0+dfsg.1-2ubuntu0.1~esm6 (package) or 1.6.6+dfsg-2ubuntu0.1+esm3 (package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro 24.04 LTSroundcubepkg:deb/ubuntu/roundcube?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTSroundcubepkg:deb/ubuntu/roundcube?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official security updates provided by Ubuntu as detailed in advisory USN-8223-1. The fixed package versions include 1.5.0+dfsg.1-2ubuntu0.1~esm6 and 1.6.6+dfsg-2ubuntu0.1+esm3. Standard system updates will apply these fixes. No additional mitigation is required once patched.
Description
A critical Cross-Site Scripting (XSS) vulnerability exists in the rcmail_action_mail_get->run() function of Roundcube Webmail versions through 1.5.7 and 1.6.x through 1.6.7. This flaw allows a remote attacker to exploit a malicious email attachment with a crafted Content-Type header to steal and send emails from a victim's account. The vulnerability has a high CVSS score of 9.3 and affects multiple Ubuntu package versions. Official patches are available from Ubuntu to remediate this issue.
References
- ubuntu.com/security/CVE-2024-42008 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-42008 (opens in a new tab)
- github.com/roundcube/roundcubemail/commit/89c8fe9ae9318c015807fbcbf7e39555fb30885d (opens in a new tab)
- github.com/roundcube/roundcubemail/releases (opens in a new tab)
- sonarsource.com/blog/government-emails-at-risk-critical-cross-site-scripting-vulnerability-in-roundcube-webmail/ (opens in a new tab)
- github.com/roundcube/roundcubemail/releases/tag/1.5.8 (opens in a new tab)
- github.com/roundcube/roundcubemail/releases/tag/1.6.8 (opens in a new tab)
- roundcube.net/news/2024/08/04/security-updates-1.6.8-and-1.5.8 (opens in a new tab)
- ubuntu.com/security/notices/USN-8223-1 (opens in a new tab)