node
Affects nodeSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 3.6 Low : upgrade to 26.12.1 when convenient.
Data as of 29 Oct 2026, 13:18 UTC
Thin evidence
One scorer or none| CNA (hackerone) | CVSS 3.0 | 3.6 |
|---|
- Patch
- Available – fixed in 26.12.1
CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N/CR:M/IR:M/AR:MExploitation evidence
Disclosed: evidence found.
CVE published 23 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade node to 26.12.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnaminodepkg:bitnami/nodeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and the issue is fixed in Node.js version 26.12.1. Users should upgrade to version 26.12.1 or later to remediate this vulnerability.
Description
A flaw in the Node.js Permission Model for filesystem enforcement allows access to filesystem paths that do not exactly match a wildcard permission rule. Specifically, when a requested path is shorter than the prefix of a wildcard grant, the permission check incorrectly treats it as a match, potentially granting unintended access. This affects Node.js versions 25.0.0 up to but not including 26.12.1 and is fixed in version 26.12.1.