Skip to main content
VulnerabilityPublished

CVE-2026-106073: node

Affects nodeSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-106073· Low 3.3

Not known to be exploited · CVSS 3.3 Low · fixed in 26.12.1 : update node when convenient.

Data as of 29 Oct 2026, 13:18 UTC

CVSS 3.0 base score
3.3Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (hackerone)CVSS 3.03.3
Patch
Available – fixed in 26.12.1, 24.22.1, 22.23.4
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade node to 26.12.1, 24.22.1 or 22.23.4.

Affected software

ProductAffectedFixed in
Bitnaminodepkg:bitnami/nodeOther threatsAffected
  • <22.23.4
  • >=23.0.0 <24.22.1
  • >=25.0.0 <26.12.1
Fixed in
  • 22.23.4
  • 24.22.1
  • 26.12.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in Node.js versions 22.23.4, 24.22.1, and 26.12.1. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation steps are indicated beyond applying the official fix.

Description

A flaw in the Node.js Permission Model filesystem enforcement causes fs.realpathSync() to bypass required read permission checks. This incomplete fix of CVE-2026-21715 allows code running with restricted --allow-fs-read permissions to use fs.realpathSync() to access filesystem paths outside permitted directories. The vulnerability affects Node.js versions 22.x, 24.x, and 26.x prior to specific fixed releases.

References

Community reviews

Loading reviews…