Skip to main content
VulnerabilityPublished Updated

CVE-2026-21715: node

Affects nodeSource GCVE Database

0
Authoritative record:CVE-2026-21715· Low 3.3

Not known to be exploited · CVSS 3.3 Low · fixed in 25.8.2 : update node when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.0 base score
3.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 25.8.2, 24.14.1, 22.22.2 +1
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade node to 25.8.2, 24.14.1, 22.22.2 or 20.20.2.

Affected software

ProductAffectedFixed in
Bitnaminodepkg:bitnami/nodeOther threatsAffected
  • <20.20.2
  • >=21.0.0 <22.22.2
  • >=23.0.0 <24.14.1
  • >=25.0.0 <25.8.2
Fixed in
  • 20.20.2
  • 22.22.2
  • 24.14.1
  • 25.8.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade Node.js to versions 20.20.2 or later, 22.22.2 or later, 24.14.1 or later, or 25.8.2 or later to ensure the issue is fixed. Until patched, avoid relying solely on the Permission Model's --allow-fs-read restrictions for security, as fs.realpathSync.native() can bypass these controls.

Description

A vulnerability in Node.js Permission Model filesystem enforcement allows the function fs.realpathSync.native() to bypass required read permission checks. This flaw affects Node.js versions 20.x, 22.x, 24.x, and 25.x when running with restricted --allow-fs-read permissions. Exploiting this issue, code can check file existence, resolve symlink targets, and enumerate filesystem paths outside permitted directories despite restrictions. The vulnerability has a low severity rating and no known exploits in the wild. Patches are available for affected versions.

References

Community reviews

Loading reviews…