CVE-2025-55132: Node.js's permission model
Affects nodeSource GCVE Database
Not known to be exploited · CVSS 2.8 Low · fixed in 25.3.0 : update node when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 25.3.0, 24.13.0, 22.22.0 +1
CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade node to 25.3.0, 24.13.0, 22.22.0 or 20.20.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnaminodepkg:bitnami/nodeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should update affected Node.js versions to the fixed releases beyond the specified affected version ranges. No additional mitigation steps are indicated by the vendor advisory.
Description
A vulnerability in Node.js's permission model allows modification of a file's access and modification timestamps via the futimes() function even when the process only has read permissions. This occurs because futimes() does not enforce the expected write-permission checks, unlike utimes(). This flaw affects Node.js versions 20.0.0 up to but not including 20.20.0, 21.0.0 up to but not including 22.22.0, 23.0.0 up to but not including 24.13.0, and 25.0.0 up to but not including 25.3.0. The vulnerability could be used to obscure file activity by altering timestamps, impacting the reliability of logs. A patch is available to address this issue.