CVE-2026-21636: Node.js's permission model
Affects nodeSource GCVE Database
Not known to be exploited · CVSS 5.8 Medium : upgrade to 25.3.0 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 25.3.0
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade node to 25.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnaminodepkg:bitnami/nodeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users of Node.js versions >=25.0.0 <25.3.0 should upgrade to a fixed version as soon as possible to remediate this issue. No additional mitigation steps are indicated beyond applying the official fix.
Description
A critical flaw in Node.js version 25's permission model allows Unix Domain Socket (UDS) connections to bypass network restrictions when the --permission flag is enabled. This vulnerability permits attacker-controlled inputs to connect to arbitrary local sockets even without the --allow-net permission, breaking the intended security boundary. This can lead to privilege escalation, data exposure, or local code execution. The issue affects Node.js versions from 25.0.0 up to but not including 25.3.0. A patch is available for this vulnerability.