Skip to main content
VulnerabilityPublished Updated

CVE-2026-21637: Node.js TLS error handling

Affects nodeSource GCVE Database

0
Authoritative record:CVE-2026-21637· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium · fixed in 25.3.0 : update node when convenient.

Data as of 26 Oct 2026, 12:29 UTC

CVSS 3.0 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.1% chance of exploitation in 30 days – higher than 65% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 25.3.0, 24.13.0, 22.22.0 +1
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade node to 25.3.0, 24.13.0, 22.22.0 or 20.20.0.

Affected software

ProductAffectedFixed in
Bitnaminodepkg:bitnami/nodeOther threatsAffected
  • <20.20.0
  • >=21.0.0 <22.22.0
  • >=23.0.0 <24.13.0
  • >=25.0.0 <25.3.0
Fixed in
  • 20.20.0
  • 22.22.0
  • 24.13.0
  • 25.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade to fixed Node.js versions beyond the affected ranges to remediate the issue. No additional mitigation is indicated beyond applying the official fix.

Description

A vulnerability in Node.js TLS error handling allows remote attackers to crash or exhaust resources of a TLS server when using pskCallback or ALPNCallback. Synchronous exceptions thrown during these callbacks bypass normal TLS error handling, causing process termination or resource leaks leading to denial of service. This affects multiple Node.js versions where these callbacks are not safely wrapped.

References

Community reviews

Loading reviews…