Skip to main content
VulnerabilityPublished Updated

CVE-2025-14512: glib. This vulnerability · Integer Overflow

Source GCVE Database

0
Authoritative record:CVE-2025-14512· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.86.3 when convenient.

Data as of 26 Oct 2026, 12:29 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.86.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade glib to 2.86.3.

Affected software

ProductAffectedFixed in
GNOMEglibAffected
  • <2.86.3
Fixed in
  • 2.86.3
Red Hatredhat/glibpkg:rpm/redhat/glibOther threatsAffected
  • =0
  • =2.56.4-169.el8_10
  • =2.80.4-10.el10_1.13
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GLib version 2.88.0 and later. Users should apply the official patches provided by Red Hat as referenced in their security advisories. No additional mitigation steps are indicated by the vendor.

Description

A heap buffer overflow and denial-of-service (DoS) vulnerability exists in GLib's GIO escape_byte_string() function due to an integer overflow when processing malicious file or remote filesystem attribute values. This flaw affects GLib versions prior to 2.88.0. The vulnerability has a medium severity rating with a CVSS score of 6.5. Red Hat has released patches addressing this issue in version 2.88.0.

References

Community reviews

Loading reviews…