CVE-2026-119727: GStreamer's gst-plugins-bad H.265 video parser · Heap-based Buffer Overflow
Source GCVE Database
Not known to be exploited · CVSS 6.5 Medium.
Data as of 30 Oct 2026, 23:36 UTC
Thin evidence
One scorer or none| CNA (redhat) | CVSS 3.1 | 6.5 |
|---|
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Red Hat Enterprise Linux 10gstreamer1-plugins-bad-free | Affected– | Fixed in– |
| Red Hat Enterprise Linux 7gstreamer1-plugins-bad-free | Affected– | Fixed in– |
| Red Hat Enterprise Linux 8gstreamer1-plugins-bad-free | Affected– | Fixed in– |
| Red Hat Enterprise Linux 9gstreamer1-plugins-bad-free | Affected– | Fixed in– |
AI-suggested
No mitigation meeting Red Hat's standards for usability and stability is currently available. Users should upgrade to versions including the upstream fix 1.28.1 or later when available. Red Hat Enterprise Linux 7 and 8 are not affected. SELinux confinement may reduce impact in confined environments. Monitor vendor advisories for patch releases.
Description
A vulnerability in GStreamer's gst-plugins-bad H.265 video parser allows a specially crafted H.265 bitstream with a Screen Content Coding (SCC) extension to trigger an integer underflow. This leads to out-of-bounds writes beyond a fixed-size array, causing memory corruption and application crashes. Exploitation requires a malformed H.265 media file and results in denial of service without confidentiality or integrity impact. Red Hat Enterprise Linux 7 and 8 are not affected; RHEL 9, 10, and Red Hat In-Vehicle OS are affected but no fix is currently available. Fedora 44 and rawhide include the fix, while Fedora 43 remains vulnerable.
References
- nvd.nist.gov/vuln/detail/CVE-2026-119727 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-119727 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2564118 (opens in a new tab)
- gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/10902.patch (opens in a new tab)
- gstreamer.freedesktop.org/security/sa-2026-0012.html (opens in a new tab)