Skip to main content
CVE-2026-55971VulnerabilityPublished Updated

Red Hat Security Advisory: RHEL AI 3.6 RPM runtime CVE fix - thrift

Affects Red HatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-55971· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade Red Hat to 0.24.0 as a priority.

Data as of 30 Oct 2026, 22:42 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.24.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Thrift to 0.24.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ThriftAffected
  • <0.24.0
Fixed in
  • 0.24.0

AI-suggested

A fix is available and included in the updated thrift packages (version 0.24.0-2.el9ai) for Red Hat Enterprise Linux AI 3.6 across supported architectures. Users should apply this update after confirming that all previously released errata relevant to their system have been installed. Follow Red Hat's official guidance on applying updates as detailed in their knowledge base article (https://access.redhat.com/articles/11258). No additional mitigation steps are indicated by the vendor.

Description

A security advisory from Red Hat addresses a vulnerability identified as CVE-2026-55971 affecting the thrift component within the Red Hat Enterprise Linux AI 3.6 platform. The advisory notes that the RPM packages involved are internal build artifacts and supported only as part of the Red Hat AI application platform. The issue is classified with high severity and is related to a CWE-122 type vulnerability. A fix has been issued as part of the Red Hat AI 3.6 update. Users are advised to apply this update after ensuring all previous relevant errata have been applied.

References

Community reviews

Loading reviews…