CVE-2026-55971: Apache Thrift · Heap-based Buffer Overflow
Affects Apache ThriftSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 0.24.0 as a priority.
Data as of 27 Oct 2026, 05:11 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.24.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Apache Thrift to 0.24.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Thrift | Affected
| Fixed in
|
AI-suggested
Users should upgrade to Apache Thrift version 0.24.0, which contains the official fix for this vulnerability. No other mitigation or temporary workaround is indicated. Patch status is confirmed by the vendor advisory recommending upgrade to 0.24.0.
Description
Heap-based Buffer Overflow vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.