Skip to main content
CVE-2026-123655VulnerabilityPublished

Moodle. Insufficient access control checks · Missing Authorization

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123655· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 5.2.4 : patch moodle soon.

Data as of 6 Nov 2026, 13:23 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (fedora)CVSS 3.17.5
Patch
Available – fixed in 5.2.4, 5.1.8, 5.0.11 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade moodle to 5.2.4, 5.1.8, 5.0.11 or 4.5.15.

Affected software

ProductAffectedFixed in
moodleAffected
  • >=5.2.0 <5.2.4
Fixed in
  • 5.2.4
moodleAffected
  • >=5.1.0 <5.1.8
Fixed in
  • 5.1.8
moodleAffected
  • >=5.0.0 <5.0.11
Fixed in
  • 5.0.11
moodleAffected
  • >=4.5.0 <4.5.15
Fixed in
  • 4.5.15
GitHubmoodlepkg:github/moodleOther threatsAffected
  • >=4.5.0 <4.5.15
  • >=5.0.0 <5.0.11
  • >=5.1.0 <5.1.8
  • >=5.2.0 <5.2.4
Fixed in
  • 4.5.15
  • 5.0.11
  • 5.1.8
  • 5.2.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat states that this vulnerability does not affect any currently supported Red Hat products. If you cannot patch yet, restricting access to Moodle installations and limiting exposure of H5P content files may reduce risk.

Description

A vulnerability in Moodle allows unauthenticated remote attackers to bypass access control checks on H5P content files. This flaw enables unauthorized viewing of restricted materials, including content in the system context and files from hidden or unavailable course modules, leading to information disclosure of protected content.

References

Community reviews

Loading reviews…