CVE-2026-123655: moodle · Missing Authorization
Affects moodleSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 5.2.4 : patch moodle soon.
Data as of 6 Nov 2026, 12:04 UTC
Thin evidence
One scorer or none| CNA (fedora) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 5.2.4, 5.1.8, 5.0.11 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade moodle to 5.2.4, 5.1.8, 5.0.11 or 4.5.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| moodle | Affected
| Fixed in
|
| moodle | Affected
| Fixed in
|
| moodle | Affected
| Fixed in
|
| moodle | Affected
| Fixed in
|
GitHubmoodlepkg:github/moodleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Fixed versions of Moodle are available: 4.5.15, 5.0.11, 5.1.8, and 5.2.4. Users should upgrade to these versions or later to remediate the vulnerability. Red Hat notes that their supported products are not affected. No additional mitigation steps are indicated beyond applying the official patches.
Description
CVE-2026-123655 is a vulnerability in Moodle affecting H5P content files where insufficient access control allows unauthenticated remote attackers to view restricted materials, including files in system context and hidden or unavailable course modules. This leads to unauthorized disclosure of protected content. The issue affects multiple Moodle versions prior to fixed releases 4.5.15, 5.0.11, 5.1.8, and 5.2.4. The vulnerability has a high severity with a CVSS score of 7.5 and is not known to be exploited in the wild. Red Hat has assessed that this vulnerability does not affect their supported products.