Skip to main content
VulnerabilityPublished Updated

CVE-2026-84269: gvfs

Affects gvfsSource GCVE Database

0
Compare
Authoritative record:CVE-2026-84269· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in 1.48.2-0ubuntu1.3 : update gvfs when convenient.

Data as of 3 Nov 2026, 23:36 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.48.2-0ubuntu1.3, 1.54.4-0ubuntu1~24.04.5, 1.60.0-1ubuntu0.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu gvfs to 1.48.2-0ubuntu1.3 (package) or 1.54.4-0ubuntu1~24.04.5 (package) or 1.60.0-1ubuntu0.2 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSgvfspkg:deb/ubuntu/gvfs?arch=source&distro=resoluteOther threatsAffected
  • <1.60.0-1ubuntu0.2
Fixed in
  • 1.60.0-1ubuntu0.2
Ubuntu 24.04 LTSgvfspkg:deb/ubuntu/gvfs?arch=source&distro=nobleOther threatsAffected
  • <1.54.4-0ubuntu1~24.04.5
Fixed in
  • 1.54.4-0ubuntu1~24.04.5
Ubuntu 22.04 LTSgvfspkg:deb/ubuntu/gvfs?arch=source&distro=jammyOther threatsAffected
  • <1.48.2-0ubuntu1.3
Fixed in
  • 1.48.2-0ubuntu1.3
Ubuntu Pro 20.04 LTSgvfspkg:deb/ubuntu/gvfs?arch=source&distro=esm-infra/focalOther threatsAffected
  • 1.42.1-1ubuntu1 – 1.44.1-1ubuntu1.2+esm1
9 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSgvfspkg:deb/ubuntu/gvfs?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 1.34.1-1ubuntu1 – 1.36.1-0ubuntu1.3.3+esm1
14 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSgvfspkg:deb/ubuntu/gvfs?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • 1.24.2-0ubuntu4 – 1.28.2-1ubuntu1~16.04.3+esm1
13 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and users should update gvfs to versions 1.48.2-0ubuntu1.3, 1.54.4-0ubuntu1~24.04.5, or 1.60.0-1ubuntu0.2 depending on their Ubuntu release. After updating, a session restart is required to apply the changes. Refer to the Ubuntu security notice USN-8970-1 for detailed update instructions.

Description

CVE-2026-84269 is a vulnerability in the AFP backend of gvfs where a malicious AFP server can cause a heap buffer overflow by sending a length that exceeds the client-requested size during share mounting. This leads to a denial of service by crashing the gvfsd-afp process. The issue is fixed in gvfs versions 1.48.2-0ubuntu1.3, 1.54.4-0ubuntu1~24.04.5, and 1.60.0-1ubuntu0.2.

References

Community reviews

Loading reviews…