Skip to main content
VulnerabilityPublished Updated

CVE-2025-6170: Stack-based Buffer Overflow

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-6170· Low 2.5

Not known to be exploited · CVSS 2.5 Low : upgrade to 2.14.5 when convenient.

Data as of 30 Oct 2026, 04:46 UTC

CVSS 3.1 base score
2.5Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.12.5
Patch
Available – fixed in 2.14.5, 10.2, 8.10.6
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade libxml2 to 2.14.5; gnome/libxml2 to 10.2 or 8.10.6.

Affected software

ProductAffectedFixed in
libxml2Affected
  • <2.14.5
Fixed in
  • 2.14.5
GitHubgnome/libxml2pkg:github/gnome/libxml2Other threatsAffected
  • =0
  • >=8.0.0 <8.10.6
  • >=10.0.0 <10.2
Fixed in
  • 8.10.6
  • 10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Patches are available from Red Hat as detailed in multiple security advisories (e.g., RHSA-2026:81127, RHSA-2026:80756). Users should apply these official fixes promptly to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2025-6170 is a vulnerability in the interactive shell of the xmllint command-line tool used for parsing XML files. The flaw arises from improper input size validation when a user inputs an overly long command, which can cause the program to crash. In rare configurations lacking modern protections, this issue might allow attackers to execute harmful code. The vulnerability has a low CVSS score of 2.5, indicating limited impact primarily causing denial of service. Red Hat has issued multiple security advisories addressing this flaw with available patches.

References

Community reviews

Loading reviews…