Skip to main content
CVE-2025-6170VulnerabilityPublished Updated

CVE-2025-6170: Red Hat Enterprise Linux 10 · Stack-based Buffer Overflow

Affects Red Hat Enterprise Linux 10Source CVE Database V5

0

Not known to be exploited · CVSS 2.5 Low : upgrade Red Hat Enterprise Linux 10 to 2.14.5 when convenient.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
2.5Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.14.5, 10.2, 8.10.6
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade libxml2 to 2.14.5; gnome/libxml2 to 10.2 or 8.10.6.

Affected software

ProductAffectedFixed in
libxml2Affected
  • <2.14.5
Fixed in
  • 2.14.5
GitHubgnome/libxml2pkg:github/gnome/libxml2Other threatsAffected
  • =0
  • >=8.0.0 <8.10.6
  • >=10.0.0 <10.2
Fixed in
  • 8.10.6
  • 10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Official patches are available from Red Hat for affected versions of libxml2 in Red Hat Enterprise Linux 8 and 10. Users should apply the updates as described in Red Hat advisories RHSA-2026:36734 and RHSA-2026:39304. No additional mitigation actions are required beyond applying these official fixes.

Description

A flaw was found in the interactive shell of the xmllint command-line tool, used for parsing XML files. When a user inputs an overly long command, the program does not check the input size properly, which can cause it to crash. This issue might allow attackers to run harmful code in rare configurations without modern protections.

References

Community reviews

Loading reviews…