CVE-2025-5318: versions less than
Affects libsshSource GCVE Database
Not known to be exploited · CVSS 5.4 Medium · fixed in 0.6.3-4.3ubuntu0.6+esm2 : update libssh when convenient.
Data as of 27 Oct 2026, 06:42 UTC
- Patch
- Available – fixed in 0.6.3-4.3ubuntu0.6+esm2, 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm4, 0.9.3-2ubuntu2.5+esm1 +2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in
|
Ubuntu Pro 16.04 LTSlibsshpkg:deb/ubuntu/libssh?arch=source&distro=esm-infra/xenialOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
A flaw was found in the libssh library in versions less than 0.11.2. An out-of-bounds read can be triggered in the sftp_handle function due to an incorrect comparison check that permits the function to access memory beyond the valid handle list and to return an invalid pointer, which is used in further processing. This vulnerability allows an authenticated remote attacker to potentially read unintended memory regions, exposing sensitive information or affect service behavior.
References
- ubuntu.com/security/CVE-2025-5318 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-5318 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-5318 (opens in a new tab)
- libssh.org/security/advisories/CVE-2025-5318.txt (opens in a new tab)
- ubuntu.com/security/notices/USN-7619-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7696-1 (opens in a new tab)