CVE-2025-5318: Red Hat Enterprise Linux 10 · Out-of-bounds Read
Affects Red Hat Enterprise Linux 10Source CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade Red Hat Enterprise Linux 10 to 0.11.2 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 1.8% chance of exploitation in 30 days – higher than 78% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.11.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade libssh to 0.11.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| libssh | Affected
| Fixed in
|
AI-suggested
Official patches are available from Red Hat for affected libssh versions in Red Hat Enterprise Linux 9 and 10. Users should apply the updated libssh packages as described in Red Hat advisories RHSA-2025:18231 and RHSA-2025:18275. For detailed update instructions, refer to https://access.redhat.com/articles/11258. Applying these updates fully mitigates the vulnerability.
Description
A flaw was found in the libssh library in versions less than 0.11.2. An out-of-bounds read can be triggered in the sftp_handle function due to an incorrect comparison check that permits the function to access memory beyond the valid handle list and to return an invalid pointer, which is used in further processing. This vulnerability allows an authenticated remote attacker to potentially read unintended memory regions, exposing sensitive information or affect service behavior.
References
- access.redhat.com/errata/RHSA-2025:18231 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:18275 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:18286 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19012 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19098 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19101 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19295 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19300 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19313 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19400 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19401 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19470 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19472 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19807 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:19864 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:20943 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:21013 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:21329 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:21829 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:22275 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:23078 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:23079 (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:23080 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:0326 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:1541 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:3461 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:3462 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-5318 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2369131 (opens in a new tab)
- libssh.org/security/advisories/CVE-2025-5318.txt (opens in a new tab)